Aranka
  •  Aranka
  • 62.25% (Friendly)
  • Newbie Topic Starter
2017-12-05T09:41:14Z
Hello,

http://rr.bondtest.nl/  but we are having some problems.
The module "Category Viewer" is placed on the Home page.
We have 4 products in there
http://rr.bondtest.nl/Product/Product1 
http://rr.bondtest.nl/Product?slug=Product3 
Only the product with a "slug" in the URL shows a correct detail page.
The 3 other products go to the product page but don't show content.

The product page is a simple page with the "Product Viewer" module in it.

We are seeing the same problem with our Shopping Cart, one URL is different then the others and only that one works.

We have tried using the default HotCakesView but that gives the same result.
Is there a configuering part that we are missing?
Aranka
  •  Aranka
  • 62.25% (Friendly)
  • Newbie Topic Starter
2017-12-11T09:00:54Z
I see that the post has been viewed a lot of times but there isn't an answer yet.
Can somebody help me.
Scippy
  •  Scippy
  • 100% (Exalted)
  • Advanced Member
2017-12-12T12:45:12Z
Hi!
I had the same problem and I've fixed after enabling multilanguage website feature. If you don't need of multilanguage you can enable it without publish other languages, but after, the selected locale in the url is added and fix this problem for me.
After this steps you can try to disable the second language, for me after this workaround work fine also with only one language enabled.
Aranka
  •  Aranka
  • 62.25% (Friendly)
  • Newbie Topic Starter
2017-12-12T16:16:41Z
Hi,

The multi language solution worked for us!
Do you have any idea what the reason for this is? I don't really understand how it works now?
How did you get the idea to make it a multi language website that would fix it.
Scippy
  •  Scippy
  • 100% (Exalted)
  • Advanced Member
2017-12-12T18:07:16Z
It is not my idea but my workaround for this issue.
I encuntered the same issue in every hotcakes installation and to fix it I need to enable the multilanguage feature with an additional language, after this I come back with only one language enabled and the product details start to work. I don’t know the reason of this.
Try and let me know if it work also for you.
Will Strohl
2017-12-19T21:17:50Z
What version(s) of Hotcakes are you seeing this issue? Also, what setting do you have for the URL provider in your site? Specifically, I'm asking about the setting in your web.config file that looks like the example below (urlFormat attribute).

<add name="DNNFriendlyUrl" 
type="DotNetNuke.Services.Url.FriendlyUrl.DNNFriendlyUrlProvider, DotNetNuke.HttpModules" 
includePageName="true" 
regexMatch="[^a-zA-Z0-9 _-]" 
urlFormat="advanced" />

Also, which multilanguage feature specifically are you enabling?
Will Strohl, Upendo Ventures
Hotcakes Cloud  | Get Support  | Code Support 
Official Cloud & Support provider for Hotcakes
Aranka
  •  Aranka
  • 62.25% (Friendly)
  • Newbie Topic Starter
2017-12-20T08:07:07Z
Hi Will,

We have HotCakes version 3.0.1 Pro installed.

This is our web.config Friendly URL code:

<add name="DNNFriendlyUrl" 
type="DotNetNuke.Services.Url.FriendlyUrl.DNNFriendlyUrlProvider, DotNetNuke.HttpModules" 
includePageName="true" 
regexMatch="[^a-zA-Z0-9 _-]" 
urlFormat="advanced" />

We just enabled the second language.
In our case our standard was dutch and we enabled English.

I hope this helps.
Scippy
  •  Scippy
  • 100% (Exalted)
  • Advanced Member
2017-12-20T08:45:08Z
I've checked the web.config and DNNFriendlyUrl is the same of above.
In two minutes you can replicate this issue
https://mmmcommerce.com/...03.00.01_CMS_Install.zip 
  • Install it selecting 'Blank Website' template and 'Italian' language or any other but different by the English default
  • Go in Commerce Administration and Start Configuration Wizard with save and continue without setting any choice to do fast
  • Click on 'Add Sample Products & Categories'
  • Go To Store in Category Viewer and click on any product and you will see an empty product details page.[/list]
    VERY IMPORTANT! I've noticed that if you start with a clean installation in English language instead any other language all work fine and this because DNN enable only English and not the selected Language in addiction to English! Then the issue must be searched in DNN installation with more than one language with English disabled!
  • Will Strohl
    2017-12-21T18:47:08Z
    Ah... I understand this issue now. This is a known issue that was logged in our original backlog. I've created a new Issue to get this resolved in a future release.

    https://github.com/HotcakesCommerce/core/issues/56 
    Will Strohl, Upendo Ventures
    Hotcakes Cloud  | Get Support  | Code Support 
    Official Cloud & Support provider for Hotcakes
    Aranka
    •  Aranka
    • 62.25% (Friendly)
    • Newbie Topic Starter
    2017-12-22T10:10:00Z
    Will,

    I am glad that it will be looked at and hopefully be resolved in a new release so that with new installations the issue won't occur.

    Francisco Pérez Andrés
    2018-01-24T11:20:50Z
    Hi,

    I have quite a similar problem in my test web: whe I click on a product, it isn't able to show the detail page and takes me to home page. I already have multilanguage activated, with only one language enabled (Spanish). If I re-enable english, the detail links are working again.

    Any idea?
    Thank you,
    Francisco
    Loading
    • Sign-up for the Hotcakes Community Newsletter: